WordPress 5.0. A Message to Our Clients

WordPress 5.0 is set to be released on November, 27th  December 6th, 2018. This version of WordPress goes far beyond an upgrade. It is a complete replacement of the Tiny MCE editor we all know. It’s also a complete change to the WordPress framework, back-end, and the way content is stored and rendered with React JavaScript. The new editor in WordPress 5.0 is called Gutenberg.

The new editor has been poorly received by the WordPress community. There are issues surrounding accessibility and backwards compatibility, combined with a poor user interface. Some older plugins and themes may be at risk.

You can learn more here:


Install the Classic Editor Plugin

WordPress has launched the Classic Editor Plugin as the official off-switch. This will keep the current WordPress and Tiny MCE environment you are used to using. We advise all clients to install and activate this plugin prior to upgrading to WordPress 5.0. It will not affect your site.

Web242 will be installing and activating the Classic Editor Plugin, for all clients on our WordPress Managed plans. At this time, we will not be updating our clients to WordPress 5.0.

We are glad to help anyone who is concerned about their WordPress site. If you have any questions or concerns, please let us know!

Leave a comment